PC SOFT

ONLINE HELP
 WINDEVWEBDEV AND WINDEV MOBILE

Home | Sign in | English EN
  • Photos et vidéos enregistrées
  • Répertoires de sauvegarde
  • Fonctionnalité d'application requise
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Lance l'application caméra native de l'appareil afin d'enregistrer une vidéo ou de prendre une photo.
Remarques :
  • iPhone/iPadWidget iOS Remarque : La syntaxe 2 utilisant un appel non bloquant est conseillée, notamment à partir de iOS 8.
  • Universal Windows 10 App La fonction CaméraLanceAppli doit être exécutée dans un thread.
  • Dans une application WINDEV, la fonction CaméraCapture peut être utilisée pour obtenir une vidéo ou prendre une photo en utilisant la caméra du périphérique.
  • Cette fonction est équivalente à la fonction VidéoLanceAppli.
Exemple
sPhoto est une chaîne
sPhoto = CaméraLanceAppli(viCaptureImage)
SI sPhoto <> "" ALORS
Info("Photo sauvegardée dans le fichier " + sPhoto)
FIN
nTypeEnregistrement est un entier
 
// Laisse l'utilisateur décider du type de capture
SI Dialogue("Souhaitez-vous enregistrer une image ou une vidéo ?", ["Une image", ...
"Une vidéo"], 1, 2, dlgIcôneQuestion) = 1 ALORS
nTypeEnregistrement = viCaptureImage
SINON
nTypeEnregistrement = viCaptureVidéo
FIN
 
// Lance l'application
CaméraLanceAppli(nTypeEnregistrement, CaméraLanceAppli_Callback)
 
PROCÉDURE INTERNE CaméraLanceAppli_Callback(sChemin est une chaîne)
 
// Si le retour vaut chaîne vide (""), une erreur a eu lieu
SI sChemin ~= "" ALORS
Erreur(ErreurInfo())
RETOUR
FIN
 
// Message de fin d'enregistrement
Info("Le fichier a été enregistré ici : " + sChemin)
FIN
Syntaxe

Lancer l'application caméra native (appel bloquant) Masquer les détails

<Résultat> = CaméraLanceAppli([<Type de capture>])
<Résultat> : Chaîne de caractères
  • Chemin complet du fichier dans lequel la photo ou la vidéo a été enregistrée,
  • Chaîne vide ("") en cas d'erreur. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Type de capture> : Constante optionnelle de type entier
Type de capture :
viCaptureImageEnregistrement d'une photo.
viCaptureVidéo
(Valeur par défaut)
Capture d'une séquence vidéo.

Lancer l'application caméra native (appel non bloquant) Masquer les détails

<Résultat> = CaméraLanceAppli([<Type de capture> [, <Procédure WLangage>]])
<Résultat> : Booléen
  • Vrai si la photo ou la vidéo a été enregistrée,
  • Faux dans le cas contraire. Pour plus de détails, utilisez la fonction ErreurInfo.
<Type de capture> : Constante optionnelle de type entier
Type de capture :
viCaptureImageEnregistrement d'une photo.
viCaptureVidéo
(Valeur par défaut)
Capture d'une séquence vidéo.
<Procédure WLangage> : Nom de procédure
Nom de la procédure WLangage (également nommée "callback") appelée lors de l'enregistrement de la photo ou de la vidéo.
Pour plus de détails sur cette procédure, consultez Paramètres de la procédure utilisée par la fonction CaméraLanceAppli.
Remarques

Photos et vidéos enregistrées

Les paramètres des photos et des vidéos enregistrées (format, résolution, taille) sont ceux définis dans le paramétrage de l'application native de prise de photos.
Si vous souhaitez afficher la photo dans un champ image il vous faudra cocher dans la description de ce champ image, volet "Détail", l'option "Orienter selon les données EXIF de l'image".

Répertoires de sauvegarde

AndroidWidget Android Dans les applications Android, la photo ou la vidéo est stockée sur la SDCard de l'appareil et est également automatiquement ajoutée à l'album.
Si des photos doivent être utilisées dans vos applications Android, il est conseillé de travailler avec des miniatures et non les photos originales prises par l'appareil. Pour générer les miniatures, utilisez la fonction CaméraGénèreMiniature.
iPhone/iPadWidget iOS Dans les applications iPhone/iPad :
Par défaut :
  • les photos sont enregistrées dans le répertoire "Documents" de l'application.
  • les vidéos sont enregistrées dans le répertoire "Tmp" de l'application.
Pour les images, il est possible également de :
  • mémoriser le contenu binaire de l'image dans une base de données, grâce à une rubrique de type Mémo.
  • ajouter la photo dans l'album photo de l'appareil grâce à la fonction AlbumSauve. Dans ce cas, l'image pourra être réutilisée grâce à la fonction AlbumSélecteur.
Universal Windows 10 App Dans les applications en mode Windows Store apps, par défaut les photos et les vidéos sont enregistrées dans le répertoire "TempState" de l'application.
Universal Windows 10 App

Fonctionnalité d'application requise

L’utilisation de cette fonction entraîne la déclaration de plusieurs fonctionnalités d'application dans l'assistant de génération de l'application.
Fonctionnalités requises :
  • Microphone : Cette fonctionnalité permet aux applications d'effectuer des enregistrements audio.
  • WebCam : Cette fonctionnalité permet aux applications d'effectuer des captures de vidéos ou de photos.
Classification Métier / UI : Code UI
Composante : wd260android.aar
Minimum version required
  • Version 22
Comments
Click [Add] to post a comment