PC SOFT

ONLINE HELP
 WINDEVWEBDEV AND WINDEV MOBILE

Home | Sign in | English EN
  • Exemple : Envoyer un fichier du poste client vers le serveur
NetSendFile (Example)
Exemple : Envoyer un fichier du poste client vers le serveur
L'exemple suivant permet de transférer un fichier du poste client vers le poste serveur et de gérer la progression du transfert sur le poste client.
// - - Code d'initialisation de la fenêtre "FEN_ClientRPC"
GLOBAL
Transfert_Terminé est un booléen = Faux
Transfert_EnCours est un booléen = Faux
Evénement("Jauge_Transfert", "FEN_ClientRPC", "EnvoieFichier")
...
UneConnexion est un entier
UneConnexion = NetConnecte("148.61.125.245", ServeurFTP, "GUEST", "")
...
// - - Bouton d'envoi du transfert
SI Transfert_EnCours = Vrai ALORS
Erreur("Un transfert de fichier est actuellement en cours")
SINON
Transfert_Terminé = Faux
Transfert_EnCours = Vrai
SI NetEnvoieFichier(UneConnexion, "C:\autoexec.bat", ...
"C:\autoexec.cli", "EnvoieFichier", 10) = Faux ALORS
Info("Échec du transfert")
FIN
...
FIN
// - - Procédure Jauge_Transfert : gestion du transfert en cours
PROCEDURE Jauge_Transfert
Message("Transfert en cours")
Jauge(_EVE.wParam, _EVE.lParam)
SI _EVE.wParam = _EVE.lParam ALORS
Transfer_EnCours = Faux
Transfert_Terminé = Vrai
Message("Transfert terminé")
Info("Transfert terminé")
FIN
Minimum version required
  • Version 9
This page is also available for…
Comments
Click [Add] to post a comment