PC SOFT

ONLINE HELP
 WINDEVWEBDEV AND WINDEV MOBILE

Home | Sign in | English EN
  • Conditions d'utilisation
  • Actions réalisables sur une archive multi-parties
  • Actions réalisables sur une archive mono-partie
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Renvoie le type de l'archive : archive mono-partie ou archive multi-parties.
Versions 17 et supérieures
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 17
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Versions 18 et supérieures
WINDEVWEBDEV - Code ServeurWindows Cette fonction gère désormais le format 7z.
Nouveauté 18
WINDEVWEBDEV - Code ServeurWindows Cette fonction gère désormais le format 7z.
WINDEVWEBDEV - Code ServeurWindows Cette fonction gère désormais le format 7z.
Versions 26 et supérieures
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Android Cette fonction est désormais disponible pour les applications Android.
Nouveauté 26
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Android Cette fonction est désormais disponible pour les applications Android.
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Android Cette fonction est désormais disponible pour les applications Android.
// Ouverture de l'archive "MonArchive"
ResOuvreArchive = zipOuvre("MonArchive", "D:\Sauvegardes\Sauvegarde.zip")
// Pour Windows Mobile :
// ResOuvreArchive = zipOuvre("MonArchive", "\Sauvegardes\Sauvegarde.zip")
 
SI ResOuvreArchive = 0 ALORS
...
FIN
// Archive mono-partie ou multi-parties ?
ResEstMulti = zipEstMulti("MonArchive")
// Affichage du résultat
SI ResEstMulti = Vrai ALORS
Info("L'archive est multi-parties")
SINON
Info("L'archive est mono-partie")
FIN
MonArchive est un zipArchive
 
// Ouverture de l'archive "MonArchive"
ResOuvreArchive = zipOuvre(MonArchive, "D:\Sauvegardes\Sauvegarde.zip")
// pour Windows Mobile :
// ResOuvreArchive = zipOuvre("MonArchive", "\Sauvegardes\Sauvegarde.zip")
 
SI ResOuvreArchive = 0 ALORS
...
FIN
// Archive mono-partie ou multi-parties ?
ResEstMulti = zipEstMulti(MonArchive)
// Affichage du résultat
SI ResEstMulti = Vrai ALORS
Info("L'archive est multi-parties")
SINON
Info("L'archive est mono-partie")
FIN
Syntaxe
<Résultat> = zipEstMulti(<Archive>)
<Résultat> : Booléen
  • Vrai si l'archive est multi-parties,
  • Faux si l'archive est mono-partie.
<Archive> : Chaîne de caractères (avec guillemets) ou variable de type zipArchive
Nom de l'archive à manipuler.
Ce nom peut correspondre :
  • soit au nom d'une archive défini avec la fonction zipOuvre ou la fonction zipCrée.
  • Versions 15 et supérieures
    WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileAjax soit au nom d'une variable de type zipArchive.
    Nouveauté 15
    WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileAjax soit au nom d'une variable de type zipArchive.
    WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileAjax soit au nom d'une variable de type zipArchive.
Remarques

Conditions d'utilisation

  • La recherche du type d'archive peut être réalisée uniquement si l'archive existe (la création d'une archive s'effectue avec la fonction zipCrée).
  • Cette fonction est disponible pour les archives au format WDZ, ZIP et 7z.
Rappel :
  • LinuxiPhone/iPad Seules les archives au format ZIP, TAR et TGZ (TAR.GZ) sont disponibles.
  • Windows Mobile Seules les archives au format ZIP sont disponibles.

Actions réalisables sur une archive multi-parties

Certaines fonctions d'archivage sont utilisables uniquement sur des archives mono-partie (ajout et suppression de fichiers, création d'un exécutable auto-extractible, ...). Pour effectuer ces opérations, il suffit de regrouper les sous-archives (zipRegroupe) pour obtenir une archive mono-partie.
A partir d'une archive multi-parties, il est uniquement possible de :

Actions réalisables sur une archive mono-partie

Toutes les fonctions d'archivage sont utilisables sur des archives mono-partie, exceptée la fonction zipRegroupe (permettant de regrouper les différentes parties d'une archive entre elles).
Classification Métier / UI : Code métier
Composante : wd260zip.dll
Minimum version required
  • Version 9
Comments
Click [Add] to post a comment