PC SOFT

ONLINE HELP
 WINDEVWEBDEV AND WINDEV MOBILE

Home | Sign in | English EN
  • Handling a Table through programming
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaReports and QueriesUser code (UMC)
WEBDEV
WindowsLinuxPHPWEBDEV - Browser code
WINDEV Mobile
AndroidAndroid Widget iPhone/iPadIOS WidgetApple WatchMac CatalystUniversal Windows 10 App
Others
Stored procedures
Inserts a table into a Word Processing control.
Example
// Insère un tableau à la position 1 de taille 3x3
TT_Tableau.InsèreTableau(1, 3, 3)
// Insère un tableau à la position du curseur de taille 3 colonnes et 2 lignes
TT_Tableau.InsèreTableau(TT_Tableau.Curseur, 3, 2)
Syntax
<Result> = <Word Processing control>.InsertTable(<Position> [, <Number of columns> [, <Number of rows>]])
<Result>: docFragment variable
Versions 24 and later
docFragment variable with the inserted fragment.
New in version 24
docFragment variable with the inserted fragment.
docFragment variable with the inserted fragment.
<Word Processing control>: Control name
Name of the Word Processing control to use.
<Position>: Integer
Position where the table will be inserted. This position is expressed in number of characters.
<Number of columns>: Optional integer
Number of columns in the table. This parameters corresponds to 1 by default.
<Number of rows>: Optional integer
Number of rows in the table. This parameters corresponds to 1 by default.
Remarks

Handling a Table through programming

A table in a Word Processing document can be handled by the WLanguage functions for managing arrays.
For example:
// Récupération du document
MonDocument est un Document <- TT_ExempleTT
// Insère un tableau à la position 1 de taille 3x3
TT_ExempleTT.InsèreTableau(1, 3, 3)
 
// Définition d'un fragment correspondant au tableau
f est un TT_ExempleTT.Valeur.Fragment(TT_ExempleTT.Curseur, 0)
 
soit para <- f.Paragraphe[1]
SI para.Tableau = Null ALORS
RETOUR
FIN
 
doc est un Document <- TT_ExempleTT.Valeur
 
// Ajoute une ligne au tableau
nIndice est un entier = Ajoute(para.Tableau.Lignes)
 
// Saisie dans la cellule 2,2
para.Tableau.Cellules[2,2].Contenu.Texte = "Je suis dans la cellule 2,2"
 
// Supprime la ligne 3
Supprime(para.Tableau.Lignes, 3)
 
// Supprime la colonne 3
Supprime(para.Tableau.Colonnes, 3)
 
// Supprime le tableau entier où se trouve le curseur
Supprime(doc.Paragraphe, para.IndiceParagraphe)
Example for creating a table in a document with the content of a Table control:
// Une fenêtre contient un champ Table mémoire nommé TABLE_Démo
// et un champ Traitement de texte nommé TT_Démo
// Le code suivant ajoute un tableau dans le champ Traitement de texte avec:
// - en première ligne du tableau, le titre des colonnes du champ Table,
// - le contenu du champ Table dans les lignes suivantes du tableau.
 
MonDoc est un Document
cTable est un Champ <- TABLE_Démo
pCol est un Champ
 
FragmentDeb est un MonDoc.docFragment(1)
FragmentDeb.MiseEnForme.PoliceTaille = 24
FragmentDeb.MiseEnForme.CouleurTexte = RougeFoncé
FragmentDeb.Texte = "Tableau dans TTX avec " + cTable.Libellé + RC + RC
 
// Insertion du tableau dans le document en mémoire ...
MonDoc.DocInsèreTableau(20, TableOccurrence(cTable, toColonne), cTable.Occurrence + 1)
 
POUR TOUT para DE MonDoc.Paragraphe
SI para.Tableau <> Null ALORS
// Pour toutes les colonnes du champ Table ...
POUR nColonne = 1 _À_ TableOccurrence(cTable, toColonne)
 
// Première ligne du tableau contient le titre des colonnes
pCol <- TableEnumèreColonne(cTable, nColonne)
para.Tableau.Cellules[1, nColonne].Contenu.Texte = pCol.Libellé
 
// Remplissage de toutes les lignes de cette colonne
POUR nLigne = 1 _À_ cTable.Occurrence
para.Tableau.Cellules[nLigne+1, nColonne].Contenu.Texte = pCol[nLigne]
FIN
FIN
SORTIR
FIN
FIN
 
// Document en mémoire affecté au champ Traitement de texte
TT_Démo = MonDoc
Component: wd270mdl.dll
Minimum version required
  • Version 23
This page is also available for…
Comments
Click [Add] to post a comment