PC SOFT

ONLINE HELP
 WINDEVWEBDEV AND WINDEV MOBILE

Home | Sign in | English EN
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
SaaSEnvoieCodeDeSécurité (Fonction)
En anglais : SaaSSendSecurityCode
Envoie le code de sécurité à l'utilisateur pour qu'il puisse changer son mot de passe.
Exemple
// Clic sur "Mot de passe oublié ?"
SI PAS SaaSEnvoieCodeDeSécurité("Marcel") ALORS
Info("Récupération du mot de passe impossible. " +
"Avez vous précisé une adresse mail dans votre profil ?")
RETOUR
FIN
 
// Validation du formulaire
SI SaaSConnecte("Marcel", SAI_Code) ALORS
// Code valide, changer le mot de passe pour un nouveau
SaaSChangeMotDePasse(SAI_NouveauMotDePasse)
FIN
Syntaxe
<Résultat> = SaaSEnvoieCodeDeSécurité(<Login> [, <Webservice>])
<Résultat> : Booléen
  • Vrai si l'envoi du code de sécurité a réussi,
  • Faux dans le cas contraire. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Login> : Chaîne de caractères (avec guillemets)
Login de l'utilisateur.
<Webservice> : Chaîne de caractères (avec guillemets) optionnelle
Webservice à utiliser. Ce paramètre correspond :
  • soit au nom de l'hôte du webservice SaaS (par exemple, "Machine", "Machine.MonReseau.fr" , "http://Mondomaine.com").
  • soit à l'URL complète du webservice SaaS (par exemple, "http://domaine.com/WDSAAS230_WEB/WDSaaS230.awws").
Par défaut, la connexion se fera au webservice SaaS installé avec le serveur d'application WEBDEV sur la machine locale.
Remarques
  • Le code de sécurité est valide tant que la session qui a émis la demande de changement de mot de passe est active.
  • Le code de sécurité est envoyé à l'adresse email indiquée dans la variable de type saasUtilisateur correspondant à l'utilisateur (propriété ..Email). Si cette propriété n'est pas renseignée, l'email est envoyé à son login (si ce login correspond à une adresse email valide).
  • Pour pouvoir envoyer le code de sécurité, il est nécessaire d'avoir configuré les paramètres SMTP de l'administrateur SaaS :
Composante : wd260com.dll
Minimum version required
  • Version 22
Comments
Click [Add] to post a comment