PC SOFT

ONLINE HELP
 WINDEVWEBDEV AND WINDEV MOBILE

Home | Sign in | English EN
  • Propriétés spécifiques à la description des variables de type xpathRésultat
  • Divers
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
xpathRésultat (Type de variable)
En anglais : xpathResult
Le type xpathRésultat permet de connaître le résultat de l'exécution d'une requête XPATH. Les caractéristiques de ce résultat peuvent être connues à l'aide de différentes propriétés WLangage.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Versions 27 et supérieures
Android Ce type de variable est désormais disponible pour les applications Android.
Widget Android Ce type de variable est désormais disponible en mode Widget Android.
Nouveauté 27
Android Ce type de variable est désormais disponible pour les applications Android.
Widget Android Ce type de variable est désormais disponible en mode Widget Android.
Android Ce type de variable est désormais disponible pour les applications Android.
Widget Android Ce type de variable est désormais disponible en mode Widget Android.
Exemple
monXPath est un xpathRésultat
monDoc est un xmlDocument = XMLOuvre("MonDoc.xml")
monXPath = XMLExécuteXPath(monDoc, "/Root/fils")
POUR TOUT xmlMonFils DE monXPath.Noeud
Trace(xmlMonFils..Texte)
FIN
clDoc est un xmlDocument = XMLOuvre(n, depuisChaîne)
c est un xpathRésultat = XMLExécuteXPath(clDoc, "/root")
SI c.EstValeur ALORS
Trace(c.Valeur)
SINON
POUR TOUT MonNoeud DE c.Noeud
Trace("Noeud : " + MonNoeud..Texte)
FIN
POUR TOUT attrib DE c.Attribut
Trace("Noeud : " + attrib.Nom)
FIN
FIN
clDoc est un xmlDocument = XMLOuvre(n, depuisChaîne)
c est un xpathRésultat = XMLExécuteXPath(clDoc, "/root/text()")
SI c.EstValeur ALORS
Trace(c.Valeur)
SINON
POUR TOUT noeud DE c.Noeud
Trace("Noeud : " + noeud..Texte)
FIN
POUR TOUT attrib DE c.Attribut
Trace("Noeud : " + attrib.Nom)
FIN
FIN
Remarques

Propriétés spécifiques à la description des variables de type xpathRésultat

Les propriétés suivantes peuvent être utilisées pour manipuler le résultat d'une requête XPATH :
Nom de la propriétéType manipuléEffet
AttributTableau de xmlAttributListe des attributs renvoyés par la requête XPath.
EstValeurBooléen
  • Vrai si le résultat XPath est une valeur,
  • Faux si le résultat XPath est un ensemble de noeuds et/ou attributs.
NoeudTableau de xmlNoeudListe des noeuds renvoyés par la requête XPath.
ValeurTous typesValeur renvoyée si la requête renvoie une valeur entière, booléenne ou texte. Cette valeur peut correspondre uniquement à une chaîne, un booléen ou un réel.

Divers

  • La liste des noeuds renvoyée n'est pas triée.
  • La norme utilisée pour la requête XPath est XPath 1.0.
Minimum version required
  • Version 21
Comments
Click [Add] to post a comment