PC SOFT

ONLINE HELP
 WINDEVWEBDEV AND WINDEV MOBILE

Home | Sign in | English EN
  • Various
  • Required permissions
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaReports and QueriesUser code (UMC)
WEBDEV
WindowsLinuxPHPWEBDEV - Browser code
WINDEV Mobile
AndroidAndroid Widget iPhone/iPadIOS WidgetApple WatchMac CatalystUniversal Windows 10 App
Others
Stored procedures
Used to disconnect from a Bluetooth Low Energy device.
Versions 27 and later
Windows This function is now available for WINDEV applications in Windows.
New in version 27
Windows This function is now available for WINDEV applications in Windows.
Windows This function is now available for WINDEV applications in Windows.
Example
myDevice is btleDevice
BTLEConnect(myDevice)
...
BTLEDisconnect(myDevice)
Syntax
BTLEDisconnect(<Device>)
<Device>: btleDevice variable
Name of btleDevice variable representing the Bluetooth device to use.
Remarks

Various

BTLEListDevice is used to list the Bluetooth LE devices accessible from the device.

Android

Required permissions

The call to this function modifies the permissions required by the application.
Required permission: BLUETOOTH.
This permission allows the applications to connect to the Bluetooth services.


Necessary versions
  • Android Bluetooth Low Energy WLanguage functions are only available on devices with Android 4.3 or later (api level 18).
    • A fatal error occurs if the function is used with an earlier system version.
    • To determine the version of Android the application is running on, use SysAndroidVersion.
  • iPhone/iPadIOS WidgetMac Catalyst The WLanguage Bluetooth Low Energy functions are available for the devices running iOS 9.
  • Versions 27 and later
    Windows Bluetooth Low Energy WLanguage functions are only available on:
    • PCs that support at least Bluetooth Low Energy 5.
    • PCs using a Blutooth dongle supporting Bluetooth Low Energy version 5 or higher.
    New in version 27
    Windows Bluetooth Low Energy WLanguage functions are only available on:
    • PCs that support at least Bluetooth Low Energy 5.
    • PCs using a Blutooth dongle supporting Bluetooth Low Energy version 5 or higher.
    Windows Bluetooth Low Energy WLanguage functions are only available on:
    • PCs that support at least Bluetooth Low Energy 5.
    • PCs using a Blutooth dongle supporting Bluetooth Low Energy version 5 or higher.
Business / UI classification: Business Logic
Component: wd270com.dll
Minimum version required
  • Version 21
This page is also available for…
Comments
Click [Add] to post a comment