PC SOFT

ONLINE HELP
 WINDEVWEBDEV AND WINDEV MOBILE

Home | Sign in | English EN
  • Use conditions
  • Actions that can be performed on a multi-part archive
  • Actions that can be performed on a single-part active
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaReports and QueriesUser code (UMC)
WEBDEV
WindowsLinuxPHPWEBDEV - Browser code
WINDEV Mobile
AndroidAndroid Widget iPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Others
Stored procedures
Returns the type of archive: single-part archive or multi-part archive.
Versions 18 and later
WINDEVWEBDEV - Server codeWindows This function now supports the 7z format.
New in version 18
WINDEVWEBDEV - Server codeWindows This function now supports the 7z format.
WINDEVWEBDEV - Server codeWindows This function now supports the 7z format.
Example
MonArchive est un zipArchive
 
// Ouverture de l'archive "MonArchive"
ResOuvreArchive = MonArchive.Ouvre("D:\Sauvegardes\Sauvegarde.zip")
// Pour Windows Mobile:
// ResOuvreArchive = MonArchive.Ouvre("\Sauvegardes\Sauvegarde.zip")
 
SI ResOuvreArchive = 0 ALORS
...
FIN
// Archive mono-partie ou multi-parties?
ResEstMulti = MonArchive.EstMulti()
// Affichage du résultat
SI ResEstMulti = Vrai ALORS
Info("L'archive est multi-parties")
SINON
Info("L'archive est mono-partie")
FIN
Syntax
<Result> = <Archive>.IsMulti()
<Result>: Boolean
  • True if the archive is a multi-part archive,
  • False if the archive is a single-part archive.
<Archive>: zipArchive variable
Name of a zipArchive variable that corresponds to the archive to use.
Remarks

Use conditions

  • The archive type can only be searched for if the archive exists (an archive is created with function <zipArchive variable>.Create).
  • This function is available for the archives in WDZ, ZIP and 7z format.
Reminder:
  • Linux Only ZIP, TAR and TGZ (TAR.GZ) archives are available.
  • Windows Mobile Only ZIP archives are available.

Actions that can be performed on a multi-part archive

Some archiving functions can only be used on the single-part archives (add and delete files, create a self-extracting executable, etc.). To perform these operations, it is sufficient to group the sub-archives (<zipArchive variable>.Merge) to obtain a single-part archive.
From a multi-part archive, you only have the ability to:

Actions that can be performed on a single-part active

All the archiving functions can be used on single-part archives, except for the <zipArchive variable>.Merge function (allowing the different parts of an archive to be grouped together).
Component: wd260zip.dll
Minimum version required
  • Version 24
This page is also available for…
Comments
Click [Add] to post a comment