PC SOFT

ONLINE HELP
 WINDEVWEBDEV AND WINDEV MOBILE

Home | Sign in | English EN
  • Propriétés spécifiques à la description des variables de type sfRésultatVideCorbeille
  • Fonctions manipulant le type sfRésultatVideCorbeille
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
sfRésultatVideCorbeille (Type de variable)
En anglais : sfEmptyRecycleBinResult
Le type sfRésultatVideCorbeille permet de connaître le résultat de la fonction SFVideCorbeille. Les caractéristiques de ce résultat peuvent être connues à l'aide de différentes propriétés
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Versions 20 et supérieures
WINDEVLinux Ce type de variable est désormais disponible pour les applications WINDEV sous Linux.
iPhone/iPad Ce type de variable est désormais disponible pour les applications iPhone/iPad.
Nouveauté 20
WINDEVLinux Ce type de variable est désormais disponible pour les applications WINDEV sous Linux.
iPhone/iPad Ce type de variable est désormais disponible pour les applications iPhone/iPad.
WINDEVLinux Ce type de variable est désormais disponible pour les applications WINDEV sous Linux.
iPhone/iPad Ce type de variable est désormais disponible pour les applications iPhone/iPad.
Exemple
// Connexion à Salesforce
Cnx est une  sfConnexion
Cnx.Login = "balthazar@gmail.com"
Cnx.MotDePasse = "azerty" + "XXB12VCZ54"
SI SFConnecte(Cnx) = Faux ALORS
Erreur("La connexion a échoué")
RETOUR
FIN
ResRequête est un sfRésultatExécuteRequête
ResRequête = SFExécuteRequête(Cnx, "SELECT Date__c,Miles__c,Contact__c FROM Mileage__c")
 
MonEnregistrement est un sfObjet
POUR TOUT MonEnregistrement DE ResRequête.Objet
Trace("---- Type : " + MonEnregistrement.Type+" | ID : " + MonEnregistrement.ID)
Trace(MonEnregistrement.Date__c + " / " + MonEnregistrement.Miles__c + " / " + ...
MonEnregistrement.Contact__c)
FIN
 
// Suppression d'un objet
tabSuppr est un tableau de chaînes
Ajoute(tabSuppr, ResRequête.Objet[1].ID)
 
ResSuppr est un tableau de sfRésultatSupprime
ResSuppr = SFSupprime(Cnx, tabSuppr)
POUR TOUT res DE ResSuppr
Trace("ID : " + res.ID + " - Suppression = " + res.Succès)
FIN
 
ResVideCorb est un tableau de sfRésultatVideCorbeille
ResVideCorb = SFVideCorbeille(Cnx, tabSuppr)
POUR TOUT res DE ResVideCorb
Trace("ID : " + res.ID + "- VideCorbeille  = " + res.Succès)
FIN
Remarques

Propriétés spécifiques à la description des variables de type sfRésultatVideCorbeille

Les propriétés suivantes peuvent être utilisées pour manipuler le résultat de la fonction SFVideCorbeille :
Nom de la propriétéType manipuléEffet
ErreurTableau de sfErreurCompte-rendu d'erreurs.
IDChaîne de caractèresIdentifiant Salesforce de l'enregistrement supprimé de la corbeille.
Cette propriété est disponible en lecture uniquement.
SuccèsBooléen
  • Vrai si la suppression de la corbeille a été effectuée,
  • Faux dans le cas contraire.
Cette propriété est disponible en lecture uniquement.

Fonctions manipulant le type sfRésultatVideCorbeille

Versions 14 et supérieures
SFVideCorbeille
Nouveauté 14
SFVideCorbeille
SFVideCorbeille
Vide les enregistrements spécifiés de la corbeille Salesforce.
Minimum version required
  • Version 14
Comments
Click [Add] to post a comment