PC SOFT

ONLINE HELP
 WINDEVWEBDEV AND WINDEV MOBILE

Home | Sign in | English EN
This content has been translated automatically. Click here to view the French version.
  • Displaying the files currently extracted
zipCurrentFile (Example)
Displaying the files currently extracted
WINDEVWEBDEV - Server codeReports and QueriesUser code (UMC)Ajax The following code is used to display, in the status bar of the window, the name of the files currently extracted.
// --Déclarations globales
GLOBAL
NomArchive est une chaîne = "MonArchive"
// --Clic sur BTN_ExtraitFichier
// Initialisation
NomRépertoire est une chaîne
FichierEnCours est une chaîne
CodeErreurCréation est un entier
CodeErreurAjout est un entier
CodeErreurExtrait est un entier
 
// Création d'une archive
CodeErreurCréation = zipCrée(NomArchive, "C:\Répertoire\Archives\ArchivePdf.zip")
 
SI CodeErreurCréation = 0 ALORS
// Sélection du répertoire
NomRépertoire = fRepSélecteur("", "", "Répertoire à ajouter")
// Ajoute la totalité des fichiers du répertoire sélectionné
// et de ses sous-répertoires dans l'archive
CodeErreurAjout = zipAjouteRépertoire(NomArchive, NomRépertoire, Vrai, zipRépertoire)
SI CodeErreurAjout = 0 ALORS
// Extraction et décompression des fichiers dans le répertoire courant
CodeErreurExtrait = zipExtraitTout(NomArchive, zipRépertoire, Aff_Jauge_Compression)
SI CodeErreurExtrait <> 0 ALORS
// Affichage du nom du fichier en cas d'erreur d'extraction
FichierEnCours = zipFichierEnCours(NomArchive)
Erreur(zipMsgErreur(CodeErreurExtrait) + " sur le fichier " + FichierEnCours)
FIN
SINON
 // Affichage du message d'erreur si les fichiers n'ont pas été ajoutés
 Erreur(zipMsgErreur(CodeErreurAjout))
FIN
SINON
// Affichage du message d'erreur si l'archive n'a pas été créée
Erreur(zipMsgErreur(CodeErreurCréation))
FIN
 
// Procédure interne utilisée pour gérer la jauge.
PROCEDURE INTERNE Aff_Jauge_Compression(FichierEnCours est une chaîne, Pourcentage est un entier)
SI Pourcentage < 100 ALORS
Jauge(Pourcentage, 100, FichierEnCours)
// Rafraîchissement de la fenêtre
Multitâche(-1)
SINON
// La compression est finie
Jauge()
FIN
FIN
Minimum version required
  • Version 9
This page is also available for…
Comments
Click [Add] to post a comment