PC SOFT

ONLINE HELP
 WINDEVWEBDEV AND WINDEV MOBILE

Home | Sign in | English EN
  • Transforming a project into a multilingual project
  • 1. Choosing the different languages
  • 2. Creating a new control
  • 3. Translation without specific tool (in WINDEV directly)
  • 3 b. Translating messages with WDMSG/WDINT
  • Display in the editor in a given language
  • Test
  • Executable
  • Deployed site
  • Special case: Translating the windows and pages proposed by default
  • Including and translating the windows and pages proposed by default
  • Report viewer
  • HFSQL windows and pages
  • User Groupware
  • Setup program
  • Windows of AAF (Automatic Application Features)
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaReports and QueriesUser code (UMC)
WEBDEV
WindowsLinuxPHPWEBDEV - Browser code
WINDEV Mobile
AndroidAndroid Widget iPhone/iPadIOS WidgetApple WatchMac CatalystUniversal Windows 10 App
Others
Stored procedures
Transforming a project into a multilingual project
This page presents the main steps to make your projects support multiple languages:
Caution: You must also manage the particular cases of various default windows and pages. For more details, see Special case: Translating the windows and pages proposed by default.

1. Choosing the different languages

  • Project
You can select the languages of the project in the project description:
  1. On the "Project" tab, in the "Project" group, click "Description".
  2. Select the "Languages" tab and click "Add".
  3. The selected languages are taken into account for all elements (open elements are automatically closed).
  • Windows, pages, reports and controls (text, input masks and images)
The different project languages are automatically managed.
Elements shared between projects that use different languages: when the element is opened in one of the projects, the additional languages are automatically added.
  • Help system (hlp or chm)
The different project languages are automatically managed.
Help systems shared between projects that use different languages: when the element is opened in one of the projects, the additional languages are automatically added.
  • Messages in the code (code, procedures, classes)
The different project languages are automatically managed.
Classes and procedures shared between projects: when the element is opened in one of the projects, the additional languages are automatically added. .

2. Creating a new control

  • Windows, pages, reports and controls (text, input masks and images)
By default, only the caption of runtime language is specified. The caption of the control must be translated into the supported languages.
  • Help system (hlp or chm)
The title of the new pages and the keywords are automatically created in English.

3. Translation without specific tool (in WINDEV directly)

  • Windows, pages, reports and controls (text, input masks and images)
Text must be translated in all window, page, report and control descriptions.
  • Help system (hlp or chm)
For the summary and the indexes: the translation must be performed in the description windows of the page.
For the content of help page: the translation must be performed after the change of display language.
  • Messages in the code (code, procedures, classes)
The translation must be performed in the message editor (Ctrl + T).

3 b. Translating messages with WDMSG/WDINT

  • Windows, pages and controls (text, input masks and images), Reports and controls (text, display mask and images), Help system (hlp or chm), Code messages (code, procedures, classes)
Extract all messages to be translated with WDMSG, translate the generated file and reintegrate the translations.
  • WINDEV messages
Extract and translate with WDINT. Generate a WDM file.

Display in the editor in a given language

  • Project
Change the display language for all project elements: on the "Display" tab, in the "Options" group, expand "Language displayed"
Caution: the default runtime language of project is not modified.
  • Windows, pages and controls (text, input masks and images)
The language of the editor changes automatically according to the language of the project.
To modify the display language for all project elements: on the "Display" tab, in the "Options" group, expand "Language displayed" (*)
  • Reports and controls (text, display mask and images)
The language of the editor changes automatically according to the language of the project.
To modify the display language for all project elements: on the "Display" tab, in the "Options" group, expand "Language displayed" (*)
  • Help system (hlp or chm)
The language of the editor changes automatically according to the language of the project
To modify the display language for all project elements: on the "Display" tab, in the "Options" group, expand "Language displayed" (*)
  • Messages in the code (code, procedures, classes)
The language of the editor changes automatically according to the language of the project.
To modify the display language for all project elements: on the "Display" tab, in the "Options" group, expand "Language displayed" (*)

Test

  • Project
The test of the project is run using the language selected as "Default language at runtime". The default language used at runtime is selected in the project description window ("Languages" tab).
  • Windows, pages and controls (text, input masks and images)
The window test is run in the default language of the project.
  • Reports and controls (text, display mask and images)
The report is tested in the default language of the project.
  • Help system (hlp or chm)
Compilation and test run in the display language of help system.
You must create as many help files as the number of languages.
  • Messages in the code (code, procedures, classes)
When testing a window or project, the messages from the code are displayed in the default language of the project.
  • WINDEV messages
Define the WDM file associated with each language in the project description:
  1. On the "Project" tab, in the "Project" group, click "Description".
  2. Select the "Language" tab.
  3. Select the desired language.
  4. In the "Miscellaneous" tab, select the WDM translation file.

Executable

  • Project
The executable is created in the default language of the project.
To change this language as soon as the executable is run, use Nation in the initialization code of the project.
Caution: the language will be modified from the call to Nation and until the next call to Nation.
  • Windows, pages and controls (text, input masks and images)
The windows are displayed in the language of the executable.
To change the display language of a window, use Nation before opening the window.
Caution: the language will be modified from the call to Nation and until the next call to Nation.
  • Reports and controls (text, display mask and images)
The reports are printed by default in the language of the executable.
To change the print language of a report, use:
  • Nation before printing the report.
    Caution: the language will be modified from the call to Nation and until the next call to Nation.
  • the iPrintingNation function.
  • Help system (hlp or chm):
    Open the help file corresponding to the desired language (WHelp).
  • Messages in the code (code, procedures, classes)
Messages are displayed in the current runtime language.
To change the language used to display the message, use Nation.
Caution: the language will be modified from the call to Nation and until the next call to Nation.
  • WINDEV messages
Define the WDM file associated with each language in the project description:
  1. On the "Project" tab, in the "Project" group, click "Description".
  2. Select the "Language" tab.

Deployed site

  • Project
The site is deployed in the default language of the project.
To change this language as soon as the deployed site is run, use Nation in the initialization code of the project.
Caution: the language will be modified from the call to Nation and until the next call to Nation.
  • Windows, pages and controls (text, input masks and images)
Pages are displayed in the language of the project.
To change the display language of a page, use Nation before opening the page.
Caution: the language will be modified from the call to Nation and until the next call to Nation.
  • Reports and controls (text, display mask and images)
By default, reports are printed in the language of the project.
To change the print language of a report, use:
  • Messages in the code (code, procedures, classes)
Messages are displayed in the current runtime language.
To change the language used to display the message, use Nation.
Caution: the language will be modified from the call to Nation and until the next call to Nation.
Special case: Translating the windows and pages proposed by default
The following elements can be automatically included in your applications or sites:
  • WINDEV preview window.
  • HFSQL windows for automatic management of HFSQL programming errors.
  • WINDEVWEBDEV - Server code windows or pages of user groupware. These elements are used to manage the connection of a user to an application and the different access levels for each user.
  • WINDEV windows of AAF (Automatic Application Features).
  • WINDEVWEBDEV - Server code the setup program, allowing the user to install his application or his site.

Including and translating the windows and pages proposed by default

These windows and pages are available in English and French by default. To support additional languages, the following operations must be performed:

Report viewer

  • Purpose
Display the report in "Preview" mode, and allow the user to print via the desired medium (printer, XML file, etc.).
  • Integration into the project
Request the integration of windows in your project:
  1. Open the project description: on the "Project" tab, in the "Project" group, click "Description".
  2. Display the "Style" tab.
  3. In "Report viewer", select "Custom (included in the project)".
  4. Select the type of customization to perform:
    • <Standard report viewer (without skin template)>: this option imports the standard print windows into your project.
    • <Standard report viewer with the skin template of the project>: this option imports the print windows corresponding to the skin template of your project.
  • Translation with WDMSG, or without specific tools
See previous paragraph.
  • Language used
The runtime language of the project will be used by default.
  • Change of language with Nation
The language changes automatically..

HFSQL windows and pages

  • Purpose
Allow the user to manage duplicate errors, integrity errors, password errors, lock errors, etc.
  • Integration into the project
On the "Project" tab, in the "Project" group, expand "Import" to import the files located in this directory:
  • WINDEV "\Programs\Data\Preset windows\HFSQL - Windows for automatic help".
  • WEBDEV - Server code "\Programs\Data\Preset pages\HFSQL - Pages for automatic help".
  • Translation with WDMSG, or without specific tools
See previous paragraph.
  • Language used
The runtime language of the project will be used by default.
  • Change of language with Nation
The language changes automatically..

User Groupware

  • Purpose
Used to manage the connection of a user to an application as well as the different access levels for each user.
  • Integration into the project
WINDEV Request the integration of windows in your project: on the "Project" tab, in the "Project" group, click "User Groupware". Select "Custom user groupware".

WEBDEV - Server code Request the integration of pages in your project: on the "Project" tab, in the "Project" group, click "User Groupware". Select "Enable the management of user groupware" and "Custom integration".
  • Translation with WDMSG, or without specific tools
See previous paragraph.
  • Language used
The runtime language of the project will be used by default.
  • Change of language with Nation
Cancel the automatic start of the first window or page from the groupware:
  • On the "Project" tab, in the "Project" group, click "User Groupware".
  • WINDEV In the "Execution" tab, select "Manual run".
  • WEBDEV - Server code In the "General" tab, select "Manual start".
Change the language with Nation (e.g. project initialization code).
Open the first window or page found in the groupware with gpwOpen.

Setup program

  • Purpose
Allow the user to install the application on his computer.
  • Integration into the project
  • WINDEV Open and translate the WDSETUP project provided with WINDEV.
  • WEBDEV - Server code Open and translate the WDSETUP project provided with WINDEV.
  • Translation with WDMSG, or without specific tools
See previous paragraph.
  • Language used
The language is automatically selected. Simply configure the language used for the setup program:
  • in the setup wizard: on the "Project" tab, in the "Generation" group, expand "Setup procedure" and select "Create setup procedure".
  • in WDInst: on the "Tools" tab, in the "Utilities" group, click "WDInst".
Caution: To use WDSetup in languages other than French or English, WDInst must be used to create the setup program.

Windows of AAF (Automatic Application Features)

Some AAFs (Automatic Application Features) use specific windows. These windows can be included in the application to be translated. List of main features that require a specific integration in order to be translated:
Related Examples:
WD ChainedList Training (WINDEV): WD ChainedList
[ + ] This example supplies the tools required to build chained lists (simple sequencing). This type of list is used to store and browse a set of values in an organized way.

In the example, a chained list is used to store buttons.
- The list is then used to hide/move the buttons in the screen, creating a dynamic menu (Sidebar).
- The list is also used to translate the buttons without having to reload the window. To do so, the French caption and the English caption are stored for each button. The advantage of this method is to keep the status of the window, especially the menu in its drop-down aspect, the information text, and so on.

Specific feature of this example:
- this example is a multilingual example (French/English).
Minimum version required
  • Version 9
This page is also available for…
Comments
Example
//Define Language
IF Language = "Portuguese" //Brasil

LanguageToCharset(languagePortuguese,15)
Nation(nationBrazilianPortuguese)
ChangeCharset(charsetCurrent,languagePortuguese,15)

ELSE IF Language = "English" //Inglaterra

LanguageToCharset(languageEnglish,0)
Nation(nationEnglish)
ChangeCharset(charsetCurrent,languageEnglish,0)

ELSE IF Language = "Spanish" //Espanha

LanguageToCharset(languageSpanish,10)
Nation(nationSpanish)
ChangeCharset(charsetCurrent,languageSpanish,10)

ELSE

LanguageToCharset(languagePortuguese,15)
Nation(nationBrazilianPortuguese)
ChangeCharset(charsetCurrent,languagePortuguese,15)

END
BOLLER
28 Apr. 2017